QoS: A Very Practical Approach, Any Scenario in 10 Minutes

Posted: August 7, 2008 in LAB TIPS, QoS
Tags: ,

 You may be thinking ..how can anyone do the QoS part in 10 minutes?

YES it’s possible! And proved…. Keep reading 🙂

I have seen many people struggling with QoS and till the last minute they are not 100 percent sure that if what that is the right solution what was asked in the monster exam. Even you have a good understanding of  QoS and you say that oh yeah, I have no problem with QoS, but just about the enormous time everyone is putting in configuring the QoS itself.

Everyone may have a different approach to win the lab game, but my approach was like this;

The whole lab has 100 points. To pass the lab we only need 80 points.
– Don’t touch LAN QoS – u hve to configure on 3 switches. CatOS is creepy, it may spike other things as well. AS u know 6608 blades are really old, applying QoS onto those older crabs may hung or may behave un-expected. I kept hearing from others that they had issues where they had to reset the 6608 blade or ethernet module. I was lucky, as here in Sydney lab I never had that kind of issue(s).

So the bottom line is, don’t be too greedy and you may safely leave some topics where you are not 100% confident (as I did). As we all know that the lab exam is not like the university exam where you’d be given points for partially correct answers.
The real benefit of leaving  non-confident topics are “Save time” and put that time in doing other things, may be you can utilize that in verifying the answers again and again until you drain your 8 hours time.

Just a side config)#do sh run int s0/3/0
Building configuration…

Current configuration : 152 bytes
!
interface Serial0/3/0
description — to frswitch
no ip address
encapsulation frame-relay
ip ospf dead-interval minimal hello-multiplier 4
end

HQ(config)#do sh run int s0/3/0.1
Building configuration…

Current configuration : 178 bytes
!
interface Serial0/3/0.1 point-to-point
description ====== To SITE-B =======
ip address 10.10.33.1 255.255.255.128
ip ospf mtu-ignore
frame-relay interface-dlci 201
end

HQ(config)#

HQ(config)#
HQ(config)#do sh run int s0/3/0.2
Building configuration…

Current configuration : 178 bytes
!
interface Serial0/3/0.2 point-to-point
description ===== To SITE-C ======
ip address 10.10.33.129 255.255.255.128
ip ospf mtu-ignore
frame-relay interface-dlci 202
end

HQ(config)#

HQ(config)#
HQ(config)#int s0/3/0.1
HQ(config-subif)#bandwidth 512
HQ(config-subif)#exit
HQ(config)#
HQ(config)#int s0/3/0.1
HQ(config-subif)#
HQ(config-subif)#!first Assign the bandwidth to this interface this is a must
HQ(config-subif)#
HQ(config-subif)#bandwidth 512
HQ(config-subif)#
HQ(config-subif)#!now the magic part
HQ(config-subif)#
HQ(config-subif)#frame-re interface-dlci 201
HQ(config-fr-dlci)#
HQ(config-frdlci)#auto qos voip trust fratm

Now lets see what MAGIC has the above command has done in your router;

Common Myth: Auto-QoS breaks many things. I had the same concept until I proved that it doesn’t break anything and is a real time saver tool.  I know all boot camps are taught not to use it, but they don’t explain you why not! May be they don’t want to tell you the secrets? Duh! (just joking) . I have never been to any bootcamp so I really don’t know what they teaches. I did everything start to finish in 9 months myself, self learning method with a few wonderful online study mates!

The other myth is wheather it is allowed in the real lab exam – yes it is, I raised this question with Ben NG on Ask Expert and his answer was “yes you can use it as long as it qualify the questions requirement” , in other word, its not just run auto-qos and thats all, you need to fine tune it.

Change#1 in existing configuration
—————————–

First, lets see if anything got changed in physical interface;

HQ(config-frdlci)#do sh run int s0/3/0
Building configuration…

Current configuration : 196 bytes
!
interface Serial0/3/0
description — to frswitch
no ip address
encapsulation frame-relay
ip ospf dead-interval minimal hello-multiplier 4
no fair-queue
frame-relay traffic-shaping <—- NEW NEW
end

HQ(config-fr-dlci)#

note; U don’t hve to remember to put that command if you are doing FRTS.

Change#2 in existing configuration
—————————–

Next, lets see what has changed on sub interace:

HQ(config-frdlci)#do sh run int s0/3/0.1
Building configuration…

Current configuration : 236 bytes
!
interface Serial0/3/0.1 point-to-point
description ====== To SITE-B =======
bandwidth 512
ip ospf mtu-ignore
frame-relay interface-dlci 201 ppp Virtual-Template200 <– WOW
class AutoQoS-FR-Se0/3/0-201 <—WOW
auto qos voip trust fratm
end

HQ(config-fr-dlci)#

Change#3 in existing configuration
—————————–

HQ(config-fr-dlci)#do sh run | be class
class-map match-any AutoQoS-VoIP-RTP-Trust
match ip dscp ef
class-map match-any AutoQoS-VoIP-Control-Trust
match ip dscp cs3
match ip dscp af31
!
!
policy-map AutoQoS-Policy-Trust
class AutoQoS-VoIP-RTP-Trust
priority percent 70
class AutoQoS-VoIP-Control-Trust
bandwidth percent 5
class class-default
fair-queue

wowthats sound really time saver here! but what about virtual template and frame-relay class?

well u won’t get everything spoon-feed 😦
but wait! shut up!

this baby feeds you everything…. ‘auto qos voiptrust fratm’is the man here!

Change#4 in existing configuration
—————————–

HQ(config-fr-dlci)#do sh run | be Virtual-Tem

frame-relay interface-dlci 201 ppp Virtual-Template200
class AutoQoS-FR-Se0/3/0-201
auto qos voip trust fratm
!
interface Serial0/3/0.2 point-to-point
description ===== To SITE-C ======
ip address 10.10.33.129 255.255.255.128
ip ospf mtu-ignore
frame-relay interface-dlci 202
!
interface Virtual-Template200 <————–WoW
bandwidth 512
ip address 10.10.33.1 255.255.255.128
ppp multilink
ppp multilink interleave
ppp multilink fragment delay 10
service-policy output AutoQoS-Policy-Trust

!Change#5 in existing configuration
—————————–

HQ(config-fr-dlci)#
HQ(config-fr-dlci)#do sh run | be map-class
map-class frame-relay AutoQoS-FR-Se0/3/0-201
frame-relay cir 512000
frame-relay bc 5120
frame-relay be 0
frame-relay mincir 512000
!
!

I think thats pretty much all you need for MLPPP scenario, for FRTS only
you need use this command:

HQ(config-subif)#interface 3/0.2 <— going to CME site for example
HQ(config-subif)#bandwidth 2048
HQ(config-subif)#
HQ(config-subif)#!now the magic part
HQ(config-subif)#
HQ(config-subif)#frame-re interface-dlci 202
HQ(config-fr-dlci)#
HQ(config-frdlci)#auto qos voip trust <— just that yes, noticed there is no “fratm

Summary of commands;

auto qos voip trust          <—- for FRTS only , no mlppp
auto qos voip trust fratm   <—- for MLPPP only

How can you save time?
——————-
1. you don’t have to look in the docCD for any command.
2. Just quickly put the above template on all sites and then copy and paste them into notepad and modify according to the questions need.

Someone who’s reading this blog must be saying that “Enough of the bullsh**t and about to close firefox/IE windows and probably mumaling about ‘oh dude come on now and get to the real life, show me how to do any QoS scenario in 10 minutes”

Hue…. you are 20 yrs+ old nowand still expecting someone will spoon feed you the QoS tricks?
ok okshowing you in a sec….

Lets take an example;

a. mark sip and h323 traffic to cs3 [ since I hate switches, I will do it on router itself].
b. hq to siteb = MLPPP,                  PVC = 512kbps
c. hq to sitec = frf.12/shapping    PVC = 2048 kbps
d.misc…. whatever

Step#1: do the marking first
config t
class-map match-any NBAR
match protocol Sip
match protocol h323

Policy-map remark
class NBAR
set dscp CS3

interface fas0/0
service-policy input remark

now thats done HQ router, do show run and copy and paste it to other routers. Note when you copy and paste to other router it may take a bit of time to see the all commands pasted on the router, just paste on siteb router and move on to site c and paste there as well. Then come back to siteb router apply service-policy input on the lan facing interface and then move on to siteC router to apply the service-policy input command.

tips1# my fas0/0 had 3 sub-interface – fas0/0.10 for server ,  fas0/0.100 – hqvoicevlan, fas0/0.1000 for datavlan. So instead of applying service policy on all 3 interface, just apply on the main one ie..e fas0/0.
wow!

tips2# I have seen most of my friends tends to be leaving data vlan at siteB for marking. So put on both data and voice vlan at siteB.

tips3# Also noticed, at siteC CME router, be careful when marking. at my home lab i had 2801 router and 2 sub-interface on fast0/0 interface e.g. fas0/0.100 = voice, fas0/0.1000 =data. So i just put my QoS service policy on fas0/0 like i did on my Hq router.

Now you all propably think that marking on router is done and wow easy 10 points. but when you read your score report u will see “ZERO”!! Damn blame the innocent  guy at http://www.ccievoice-assessor.com/ coz he graded your lab wrong! May be he was in a pub just before he got back and went straight into your pod to start grading it!!

Think about SITEC where you’ve h323 RAS traffic also needs to be marked to CS3. You probably applied the QoS service-policy on fas0/0 [in my scenario above] and when dialpeer tries eastiblishing a call to hq, h323 signaling straight hits to WAN interface.
Think about it! , you’ve applied marking on fas0/0 , when you confirm the QoS marking u won’t see that h323 protocol counters in the show policy-map interface command.
bummer!

So above practice is just to mark signaling stuffs on each routers – max time 2-3 minutes. [not for the guys who don’t know where “q” key is in the keyboard]. BTW people call me sometime a stenographer coz my typing speed is like those people who type really fast without looking at the keyboard [touch typeing]

Now remaining 7 minutes and I have the whole QoS job to bind up. . damn it doen’st look right.

STEP#2 Everything else, apart from marking;   s0/3/0.1 = hq to siteb , s0/3/0.2 hq to sitec

config t
HQ(config)#int s0/3/0.1
HQ(config-subif)#
HQ(config-subif)#!first Assign the bandwidth to this interface this is a must
HQ(config-subif)#
HQ(config-subif)#bandwidth 512
HQ(config-subif)#!now the magic part
HQ(config-subif)#frame-re interface-dlci 201
HQ(config-frdlci)#auto qos voip trust fratm
exit

apply that command to siteb as well. at siteC router just use ‘auto qos voip trust’ for frf.12 or frts
STEP#3 copying/pasting and modifying parameters in notepad to/from router. MAX time = 4 minutes

Do ‘show run’ pipe out the class-map+map-class+virtual-template and paste them into the notepad.
HQ(config-fr-dlci)#do sh run | be class

class-map match-any AutoQoS-VoIP-RTP-Trust
match ip dscp ef
class-map match-any AutoQoS-VoIP-Control-Trust
match ip dscp cs3
match ip dscp af31
!
!
policy-map AutoQoS-Policy-Trust <—– use this default for HQ-2-siteB
class AutoQoS-VoIP-RTP-Trust
priority percent 70
class AutoQoS-VoIP-Control-Trust
bandwidth percent 5
class class-default
fair-queue

interface Virtual-Template200 <————–WoW
bandwidth 512
ip address 10.10.33.1 255.255.255.128
ppp multilink
ppp multilink interleave
ppp multilink fragment delay 10
service-policy output AutoQoS-Policy-Trust
!

HQ(config-fr-dlci)#
HQ(config-fr-dlci)#do sh run | be map-class
map-class frame-relay AutoQoS-FR-Se0/3/0-201
frame-relay cir 512000
frame-relay bc 5120
frame-relay be 0
frame-relay mincir 512000
!

Within your notepad, copy and paste the policy-map (above) commands, we need to prepare that for hq to siteC.
policy-map AutoQoS-Policy-Trust-SITEC <—– copy and paste within notepad rename end of itSITEC
class AutoQoS-VoIP-RTP-Trust
priority percent 70 <————change them if required
class AutoQoS-VoIP-Control-Trust
bandwidth percent 5 <———-change them whatever u want
class class-default
fair-queue

another copy and paste business withing notepad;

frame-relay cir 512000 <— that shud be 95% of pvc according to the QoS SRND
frame-relay bc 5120 <——-ditto—-
frame-relay be 0
frame-relay mincir 512000 —-ditto—-

tips#?# press ctrl + h in notepad put infront of find – 5120 , replace-with 4864 (95% of pvc), and hit replace all.. bingour all 3 parameters are replaced now. do the same for hq to siteC frame-relay pvc parameters.

Once everything is ready in notepad, paste above parameters back to routers. Make a note that hq and siteC frame-relay class-map name could be different and also under map-class service-policy statement u need to remove the existing one first then type the new one ‘service-policy output autoqos-blah–sitec
paste pvc parameters at the same time.

Last step4# verification

show policy-map interface and check the counters.

break-down of time is;

3 minutes = marking
3 minutes = applying autoqos
4 minutes = modifying parameter and pasting them back to router and verification.

First time when I did this practice, it used to take my 30-40 minutes. Gradually when I knew inside out where to modify and how to use notepad I really reduced it down to 10 minutes. Believe me, its doeable, just matter of the practice.

do this practice 10 times and when u reach to 11th then u will see oh, QoS is only 10 minute job.

Note, I haven’t included the time in reading the QoS question in above 10 minute business.

The other important tip is, read the question 3 times and verify that if the solution u are working on is going in the right direction.

Pushkar Bhatkoti
CCIE voice #21569

PS: if anyone who found this article useful, don’t forget to send me a post card. LOL :=)

Advertisements
Comments
  1. maqsood says:

    Hatoff to u r efforts , i really liked u r blog, about QOS and IPMA. The voice lab strategy was pretty good ,, i decided i will follow u r strategy ,, device approach with dependency config fully configured,, and also iam regular visitor to voiceie.com,,i have read u r comments on it…
    i will keep this blog in my favorite list.

  2. […] Bhatkoti’s blog – QoS in 10 minutes? (ht: […]

  3. sahil says:

    Hi Push,
    Thanks for you article.As per your qos article you state ” AS u know 6608 blades are really old, applying QoS onto those older crabs may hung or may behave un-expected.”

    Have you applied to qos to a 6608, have you got a link for that?
    Thanks
    Sahil

  4. Joro says:

    Thanks !!!

  5. pushkarbhatkoti says:

    Hi Sahil,
    I applied the QoS in production network and got 6608 whole blade stucked. the only option I had was reset the blade and everything came up but to find that out it took about 4 hours.

    On top of that, I found that my MOH was sucked over the WAN coz xcoder was deactivated.

    HTH
    -push

  6. mdury says:

    Mr. Pushkar,
    I just wanted to say thank you for all your help.
    Your IPMA/QOS methods are great.

    Thanks again

  7. Bala says:

    Hi,

    Million thanks for this article, any simple way like this for LAN QOS ? 6608 and 3550.

  8. goolloog says:

    I here the newcomer. Not absolutely I will understand with topic. Explain, please. http://kopitop.ru/map.html

  9. pushkarbhatkoti says:

    Hi Bala,
    I would say, not to waste time on LAN QoS. Try collecting points on other sections. LAN QoS may take more time and there are a lot of mistakes. I have discussed this with Ben NG and he said on netpro forum that if you leave LAN QoS that does’nt affect other sections.
    So it would be safe. I never tried doing LAN QoS. Remember you only need 80 points and not 100%.

    HTH
    -Push
    CCIE#21569

  10. Zevier says:

    Hi Push,
    But in this article, you have solved LAN QoS requirement on the Router using NBAR; so now are you saying that even though it can be done, but no grade/points should be expected?
    Thanks
    Zevier.

  11. Hi Push,

    I gotta say I really like your blog, beside you seem to be a very funny person, I really enjoy your comments and thanks for helping us on achieving the CCIE Voice lab, I liked the QoS, IPMA and VPIM, even though I am looking for a license for VPIM in Unity and I couldn’t find one.

    Thanks a millions mate.

    Andy

  12. Suukkoo says:

    HI Push,
    I have been an issue to get ride on this qustion, could you please help me
    for the same

    virtual template for the frame relay link between hq and Branch 1. compression to prevent additional bandwidth consumption.link is 384kbps.

    Use FRF.12 for the frame relay link between hq and Branch 2. Use an efficient link mechanism to limit serialization delay (maximum 10ms). The PVC for this link is 768kbps. Do not use class-based.

    any of the above allow priority for up to 6 calls, reserve 10% of bandwidth for signaling and use CBWFQ for all other traffic. Don’t use the percent command to apply. Do not use header compression in the link going to BR2

    When traffic reaches over 50% of the PVC all packets should be remarked to DSCP0 prior to being forwarded.

    I have got “0” in QOS three, times and now this is my last chance and i wanted your comments on this.

    Regards
    Suukkoo

    • pushkarbhatkoti says:

      Hi Suukkoo,
      I believe that your question is related to real lab and I wish I can help you with this but it will break NDA if I answer it.
      But I can give you some hints:
      check for wording – LFI or FRF.12 (two type of frame-relay scenario).
      Compression always on RTP stream/header-compression
      use my method to generate the class/policy/map-class and copy paste in the notepad to tune the required parameters and then paste it back to your routers.
      do not use class-base – definitely you need to use something else – i.e. rate-limit or somthing like that?

      Good luck and I bet you’ll nail it down.

      PS: since you work for Cisco so i am extra careful to answer you 🙂

  13. […] A practical approach- QoS in 10 minutes (any scenario) […]

  14. jeff says:

    Would you not also include Skinny in the Class-map NBAR for site b since phones need to communicate with Call Manager via Wan?

  15. spark says:

    Thanks for blogging, this great stuff.

  16. Neil Anderson says:

    Yeah leave out the hard bits on the lab like qos, dial plan, unity, and callmanager express. Just do the easy bits.

  17. shivlu jain says:

    really a good article

  18. dreamforccie says:

    Hi Pushkar, thanks for the procedure, it will help a lot. 🙂

  19. copy DVD says:

    How it can be defined?

  20. s k sham says:

    HI ! THISH IS SHAM .

  21. George says:

    Hi Pushkar, very good info that you have compiled over many years. Good reading and will continue to read your blog:-)

Leave a Reply , I will reply ASAP

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s